Issue with LINE version 12.0.0 for iOS and iPadOS (liff.sendMessages, liff.getContext)
Incident Report for LINE API
Resolved
The outage has been resolved. For more information, see the LINE Developers site.
https://developers.line.biz/en/news/2022/01/14/liff-outage/
Posted Jan 19, 2022 - 21:57 JST
Monitoring
We started publishing the latest iOS LINE 12.0.1 to end users. When users start using this version, the issue will be solved.
So we changed the incident status to "Operational". Now we're monitoring if the case of error will decrease in order to confirm the solution to the issue is provided to users properly.
Posted Jan 16, 2022 - 09:51 JST
Update
Affected entry points
- Rich Menu
- Rich Messages
- Chat > Hamburger menu > Notes > OGP's Link (Added 20:20 1/14)

(This affected entry points list will be updated as soon as we find more)
Posted Jan 14, 2022 - 20:21 JST
Update
Affected APIs
- liff.sendMessages()
-- returns 403
- liff.getContext()
-- returns "none" as "type"

(This affected API list will be updated as soon as we find more)
Posted Jan 14, 2022 - 12:03 JST
Update
We found that not only Rich Menu but Rich Messages are also affected.
Whether there are more routes which are affected is still under investigation.
Posted Jan 13, 2022 - 22:34 JST
Investigating
We found that liff.sendMessages() doesn’t work properly when a user got into a LIFF app via Rich Menu on the latest LINE iOS/iPad 12.0.0. (API returns 403 error)
We are continuing to investigate this issue. Sorry for the inconvenience.
Posted Jan 13, 2022 - 20:48 JST
This incident affected: LINE Front-end Framework (LIFF).